summaryrefslogtreecommitdiffstats
path: root/axiom/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2013-02-16 18:30:45 +0100
committerGravatar Martin Szulecki2013-02-16 18:30:45 +0100
commit7d61535076aa1ca484f453594b29e2ca052c2505 (patch)
tree17c558addadc0ac4f1c9843271ab3f3e678da2ac /axiom/configure.ac
parent37268e184e6f5202c34b00be2478f33f8819d0ee (diff)
downloadaxis2c-7d61535076aa1ca484f453594b29e2ca052c2505.tar.gz
axis2c-7d61535076aa1ca484f453594b29e2ca052c2505.tar.bz2
Fix building with mingw and make sure linking generates proper DLL files
Diffstat (limited to 'axiom/configure.ac')
-rw-r--r--axiom/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/axiom/configure.ac b/axiom/configure.ac
index d3cdd1f..9cee511 100644
--- a/axiom/configure.ac
+++ b/axiom/configure.ac
@@ -89,6 +89,20 @@ AC_CHECK_HEADERS([linux/if.h],[],[],
#endif
])
+dnl Check for cygwin and mingw builds to allow building DLLs
+WIN32_EXTRA_LIBADD=
+WIN32_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-cygwin*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+ *-*-mingw*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+esac
+AC_SUBST(WIN32_EXTRA_LIBADD)
+AC_SUBST(WIN32_EXTRA_LDFLAGS)
+
dnl This is a check to see if we are running MacOS X
dnl It may be better to do a Darwin check
AC_CHECK_HEADER([sys/appleapiopts.h],