summaryrefslogtreecommitdiffstats
path: root/guththila/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2013-02-16 18:30:45 +0100
committerGravatar Martin Szulecki2013-02-16 18:30:45 +0100
commit7d61535076aa1ca484f453594b29e2ca052c2505 (patch)
tree17c558addadc0ac4f1c9843271ab3f3e678da2ac /guththila/configure.ac
parent37268e184e6f5202c34b00be2478f33f8819d0ee (diff)
downloadaxis2c-7d61535076aa1ca484f453594b29e2ca052c2505.tar.gz
axis2c-7d61535076aa1ca484f453594b29e2ca052c2505.tar.bz2
Fix building with mingw and make sure linking generates proper DLL files
Diffstat (limited to 'guththila/configure.ac')
-rw-r--r--guththila/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/guththila/configure.ac b/guththila/configure.ac
index 38934f1..34e4bee 100644
--- a/guththila/configure.ac
+++ b/guththila/configure.ac
@@ -67,6 +67,19 @@ if test "$GCC" = "yes"; then
CFLAGS="$CFLAGS -ansi -ggdb3 -Wall -Wno-implicit-function-declaration "
fi
+dnl Check for cygwin and mingw builds to allow building DLLs
+WIN32_EXTRA_LIBADD=
+WIN32_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-cygwin*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+ *-*-mingw*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+esac
+AC_SUBST(WIN32_EXTRA_LIBADD)
+AC_SUBST(WIN32_EXTRA_LDFLAGS)
dnl Checks for header files.
AC_HEADER_STDC