summaryrefslogtreecommitdiffstats
path: root/guththila/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2013-02-16 18:30:45 +0100
committerGravatar Martin Szulecki2013-02-16 18:30:45 +0100
commit7d61535076aa1ca484f453594b29e2ca052c2505 (patch)
tree17c558addadc0ac4f1c9843271ab3f3e678da2ac /guththila/src/Makefile.am
parent37268e184e6f5202c34b00be2478f33f8819d0ee (diff)
downloadaxis2c-7d61535076aa1ca484f453594b29e2ca052c2505.tar.gz
axis2c-7d61535076aa1ca484f453594b29e2ca052c2505.tar.bz2
Fix building with mingw and make sure linking generates proper DLL files
Diffstat (limited to 'guththila/src/Makefile.am')
-rw-r--r--guththila/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/guththila/src/Makefile.am b/guththila/src/Makefile.am
index 5df4bce..67f0b41 100644
--- a/guththila/src/Makefile.am
+++ b/guththila/src/Makefile.am
@@ -14,8 +14,6 @@
# limitations under the License.
lib_LTLIBRARIES = libguththila.la
-libguththila_la_LDFLAGS = -version-info $(VERSION_NO)
-
libguththila_la_SOURCES = guththila_buffer.c \
guththila_namespace.c \
guththila_token.c \
@@ -27,6 +25,8 @@ libguththila_la_SOURCES = guththila_buffer.c \
libguththila_la_LIBADD = ../../util/src/libaxutil.la
+libguththila_la_LDFLAGS = -version-info $(VERSION_NO) $(WIN32_EXTRA_LDFLAGS)
+
INCLUDES = -I$(top_builddir)/include \
-I ../../util/include