summaryrefslogtreecommitdiffstats
path: root/samples/codegen/client/interop_doc2/Makefile.am
diff options
context:
space:
mode:
authorGravatar gmcdonald2010-02-13 01:32:03 +0000
committerGravatar gmcdonald2010-02-13 01:32:03 +0000
commit0425aadc78680e53000fd0108b540d6eca048516 (patch)
tree8ec7ab8e015d454c5ec586dfc91e05a2dce1cfc0 /samples/codegen/client/interop_doc2/Makefile.am
downloadaxis2c-0425aadc78680e53000fd0108b540d6eca048516.tar.gz
axis2c-0425aadc78680e53000fd0108b540d6eca048516.tar.bz2
Moving axis svn, part of TLP move INFRA-2441
git-svn-id: http://svn.apache.org/repos/asf/axis/axis2/c/core/trunk@909681 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'samples/codegen/client/interop_doc2/Makefile.am')
-rw-r--r--samples/codegen/client/interop_doc2/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/samples/codegen/client/interop_doc2/Makefile.am b/samples/codegen/client/interop_doc2/Makefile.am
new file mode 100644
index 0000000..1208385
--- /dev/null
+++ b/samples/codegen/client/interop_doc2/Makefile.am
@@ -0,0 +1,42 @@
+prgbindir = $(prefix)/bin/samples
+prgbin_PROGRAMS = test_echo_string test_echo_struct test_echo_string_array
+samplesdir = $(prefix)/samples/client/WSDLInteropTestDocLitService
+
+test_echo_string_SOURCES = \
+ axis2_ArrayOfstring_literal.c axis2_echoStringArray.c axis2_echoStringArrayResponse.c \
+ axis2_echoString.c axis2_echoStringResponse.c axis2_echoStruct.c axis2_echoStructResponse.c \
+ axis2_echoVoid.c axis2_echoVoidResponse.c axis2_SOAPStruct.c axis2_WSDLInteropTestDocLitService_stub.c \
+ test_echo_string.c
+test_echo_string_LDADD = \
+ $(LDFLAGS) -L$(AXIS2C_HOME)/lib -laxutil -laxis2_axiom \
+ -laxis2_wsdl -laxis2_engine -laxis2_parser -lpthread -laxis2_http_sender \
+ -laxis2_http_receiver \
+ $(GUTHTHILA_LIBS)
+
+test_echo_struct_SOURCES = \
+ axis2_ArrayOfstring_literal.c axis2_echoStringArray.c \
+ axis2_echoStringArrayResponse.c axis2_echoString.c \
+ axis2_echoStringResponse.c axis2_echoStruct.c axis2_echoStructResponse.c \
+ axis2_echoVoid.c axis2_echoVoidResponse.c axis2_SOAPStruct.c \
+ axis2_WSDLInteropTestDocLitService_stub.c test_echo_struct.c
+test_echo_struct_LDADD = \
+ $(LDFLAGS) -L$(AXIS2C_HOME)/lib -laxutil -laxis2_axiom \
+ -laxis2_wsdl -laxis2_engine -laxis2_parser -lpthread -laxis2_http_sender \
+ -laxis2_http_receiver \
+ $(GUTHTHILA_LIBS)
+
+test_echo_string_array_SOURCES = \
+ axis2_ArrayOfstring_literal.c axis2_echoStringArray.c \
+ axis2_echoStringArrayResponse.c axis2_echoString.c \
+ axis2_echoStringResponse.c axis2_echoStruct.c axis2_echoStructResponse.c \
+ axis2_echoVoid.c axis2_echoVoidResponse.c axis2_SOAPStruct.c \
+ axis2_WSDLInteropTestDocLitService_stub.c test_echo_string_array.c
+test_echo_string_array_LDADD = \
+ $(LDFLAGS) -L$(AXIS2C_HOME)/lib -laxutil -laxis2_axiom \
+ -laxis2_wsdl -laxis2_engine -laxis2_parser -lpthread -laxis2_http_sender \
+ -laxis2_http_receiver \
+ $(GUTHTHILA_LIBS)
+
+INCLUDES = -I$(AXIS2C_HOME)/include \
+ @UTILINC@ \
+ @AXIOMINC@