summaryrefslogtreecommitdiffstats
path: root/src/core/transport/http/common/Makefile.am
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2013-02-16 18:11:19 +0100
committerGravatar Martin Szulecki2013-02-16 18:11:19 +0100
commit8ffb051a30cdd12f682dbfce5a293160c260a65c (patch)
treec48b1f8b025379abcb92ec097bda5fd6f359ac5b /src/core/transport/http/common/Makefile.am
parentb0eb675fda9e2ebe316a41ed1e7bd4822513aa7d (diff)
downloadaxis2c-8ffb051a30cdd12f682dbfce5a293160c260a65c.tar.gz
axis2c-8ffb051a30cdd12f682dbfce5a293160c260a65c.tar.bz2
Fix circular dependency between engine and http/common transport
The circular dependency prevents proper cross compilation. A proper long-term solution requires refactoring of the affected code.
Diffstat (limited to 'src/core/transport/http/common/Makefile.am')
-rw-r--r--src/core/transport/http/common/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/core/transport/http/common/Makefile.am b/src/core/transport/http/common/Makefile.am
index 73beac3..84b6548 100644
--- a/src/core/transport/http/common/Makefile.am
+++ b/src/core/transport/http/common/Makefile.am
@@ -14,9 +14,6 @@
# limitations under the License.
lib_LTLIBRARIES = libaxis2_http_common.la
-libaxis2_http_common_la_LIBADD=$(top_builddir)/util/src/libaxutil.la\
- $(top_builddir)/src/core/transport/http/util/libaxis2_http_util.la
-
libaxis2_http_common_la_SOURCES = http_header.c\
http_out_transport_info.c\
http_request_line.c\
@@ -28,6 +25,9 @@ libaxis2_http_common_la_SOURCES = http_header.c\
simple_http_svr_conn.c\
http_worker.c
+libaxis2_http_common_la_LIBADD= $(top_builddir)/util/src/libaxutil.la\
+ $(top_builddir)/src/core/transport/http/util/libaxis2_http_util.la\
+ $(top_builddir)/src/core/engine/libaxis2_engine.la
libaxis2_http_common_la_LDFLAGS = -version-info $(VERSION_NO)