summaryrefslogtreecommitdiffstats
path: root/axiom/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'axiom/configure.ac')
-rw-r--r--axiom/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/axiom/configure.ac b/axiom/configure.ac
index d3cdd1f..9cee511 100644
--- a/axiom/configure.ac
+++ b/axiom/configure.ac
@@ -89,6 +89,20 @@ AC_CHECK_HEADERS([linux/if.h],[],[],
#endif
])
+dnl Check for cygwin and mingw builds to allow building DLLs
+WIN32_EXTRA_LIBADD=
+WIN32_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-cygwin*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+ *-*-mingw*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+esac
+AC_SUBST(WIN32_EXTRA_LIBADD)
+AC_SUBST(WIN32_EXTRA_LDFLAGS)
+
dnl This is a check to see if we are running MacOS X
dnl It may be better to do a Darwin check
AC_CHECK_HEADER([sys/appleapiopts.h],