summaryrefslogtreecommitdiffstats
path: root/guththila/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'guththila/configure.ac')
-rw-r--r--guththila/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/guththila/configure.ac b/guththila/configure.ac
index 38934f1..34e4bee 100644
--- a/guththila/configure.ac
+++ b/guththila/configure.ac
@@ -67,6 +67,19 @@ if test "$GCC" = "yes"; then
CFLAGS="$CFLAGS -ansi -ggdb3 -Wall -Wno-implicit-function-declaration "
fi
+dnl Check for cygwin and mingw builds to allow building DLLs
+WIN32_EXTRA_LIBADD=
+WIN32_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-cygwin*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+ *-*-mingw*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+esac
+AC_SUBST(WIN32_EXTRA_LIBADD)
+AC_SUBST(WIN32_EXTRA_LDFLAGS)
dnl Checks for header files.
AC_HEADER_STDC