summaryrefslogtreecommitdiffstats
path: root/neethi/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'neethi/configure.ac')
-rw-r--r--neethi/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/neethi/configure.ac b/neethi/configure.ac
index 688f53d..fc4cb82 100644
--- a/neethi/configure.ac
+++ b/neethi/configure.ac
@@ -113,6 +113,21 @@ dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([stdio.h stdlib.h string.h])
AC_CHECK_HEADERS([sys/socket.h])
+
+dnl Check for cygwin and mingw builds to allow building DLLs
+WIN32_EXTRA_LIBADD=
+WIN32_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-cygwin*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+ *-*-mingw*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+esac
+AC_SUBST(WIN32_EXTRA_LIBADD)
+AC_SUBST(WIN32_EXTRA_LDFLAGS)
+
dnl This is a check to see if we are running MacOS X
dnl It may be better to do a Darwin check
AC_CHECK_HEADER([sys/appleapiopts.h],