summaryrefslogtreecommitdiffstats
path: root/util/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'util/configure.ac')
-rw-r--r--util/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/util/configure.ac b/util/configure.ac
index 65555da..ccb808b 100644
--- a/util/configure.ac
+++ b/util/configure.ac
@@ -196,6 +196,20 @@ AC_SUBST([PLATFORM])
AC_DEFINE([HOST_OS_MINGW], 1, [define if we are on mingw])
+dnl Check for cygwin and mingw builds to allow building DLLs
+WIN32_EXTRA_LIBADD=
+WIN32_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-cygwin*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+ *-*-mingw*)
+ WIN32_EXTRA_LDFLAGS="-no-undefined -avoid-version"
+ ;;
+esac
+AC_SUBST(WIN32_EXTRA_LIBADD)
+AC_SUBST(WIN32_EXTRA_LDFLAGS)
+
AC_MSG_CHECKING(whether to build guththila xml parser library)
AC_ARG_ENABLE(guththila, [ --enable-guththila build guththila xml parser library wrapper. default=no],
[ case "${enableval}" in