summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar snowdrop2006-02-18 20:14:35 +0000
committerGravatar snowdrop2006-02-18 20:14:35 +0000
commitd45b4bc26f330d2ce29e4a06ffdae74d82e8b43b (patch)
treed4b985c32b1246f5cde7c294b6654b27f71cc81b /configure.ac
parent29b034ec9c827c7311e69fcb5765ef4e43478c29 (diff)
downloadcsoap-d45b4bc26f330d2ce29e4a06ffdae74d82e8b43b.tar.gz
csoap-d45b4bc26f330d2ce29e4a06ffdae74d82e8b43b.tar.bz2
added basic authentication and SOAP-Header capabilities for request objects
Thanks to Heiko Ronsdorf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 2f9cdae..5ad6b14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,7 +83,6 @@ AC_SUBST(NANOHTTP_RELEASE)
AC_SUBST(NANOHTTP_VERSION)
-
# Process this file with autoconf to produce a configure script.
#AC_INIT(FULL-PACKAGE-NAME, VERSION, BUG-REPORT-ADDRESS)
#AC_INIT(src/csoap.c)
@@ -93,24 +92,26 @@ AC_SUBST(NANOHTTP_VERSION)
AC_PROG_CC
AM_PROG_LIBTOOL
-# Checks for libraries.
-
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS([arpa/inet.h netdb.h string.h sys/socket.h])
+AC_HEADER_TIME
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h malloc.h netdb.h netinet/in.h stdint.h stdlib.h signal.h pthread.h string.h sys/socket.h sys/time.h unistd.h io.h stdio.h stdarg.h errno.h ctype.h openssl/rand.h openssl/err.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
-AC_HEADER_TIME
AC_STRUCT_TM
-dnl Checks for library functions.
-#AC_FUNC_MALLOC
-AC_FUNC_VPRINTF
-AC_CHECK_FUNCS([gethostbyname socket])
+AC_TYPE_SIGNAL
+AC_TYPE_SIZE_T
AC_CHECK_TYPE(ssize_t, int)
+AC_FUNC_MALLOC
+AC_FUNC_VPRINTF
+AC_FUNC_STRFTIME
+AC_FUNC_SELECT_ARGTYPES
+AC_CHECK_FUNCS([gethostbyname inet_ntoa localtime_r memmove memset mkdir select socket strchr strdup strncasecmp strpbrk strspn strstr strtol])
+
# ------------------------------------------
dnl Check socket library (for Solaris)
# ------------------------------------------