summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar m0gg2006-11-19 09:40:14 +0000
committerGravatar m0gg2006-11-19 09:40:14 +0000
commit949a8d0b46d6baa9f42c2f8c3bd5e3bdc3596cbd (patch)
tree1dfd1fd7cc3cb62bf300ae62ad306a66e674dc20 /configure.ac
parentaa366f7be60c02168422bb713ef0e5a447bf07ea (diff)
downloadcsoap-949a8d0b46d6baa9f42c2f8c3bd5e3bdc3596cbd.tar.gz
csoap-949a8d0b46d6baa9f42c2f8c3bd5e3bdc3596cbd.tar.bz2
nanohttp admin patch; code cleanup
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8f60075..e7433f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,7 +41,7 @@ dnl checks for headers
dnl
AC_HEADER_STDC
AC_HEADER_TIME
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h malloc.h netdb.h netinet/in.h stdint.h stdlib.h signal.h pthread.h string.h sys/socket.h sys/time.h unistd.h io.h stdio.h stdarg.h errno.h ctype.h openssl/rand.h openssl/err.h])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h malloc.h netdb.h netinet/in.h stdint.h stdlib.h signal.h pthread.h string.h sys/socket.h sys/time.h unistd.h io.h stdio.h stdarg.h errno.h ctype.h openssl/ssl.h openssl/rand.h openssl/err.h])
dnl
dnl Checks for typedefs, structures, and compiler characteristics.
@@ -364,6 +364,11 @@ AC_ARG_WITH(ssl,
CHECK_SSL
+#---------------------------------------------
+# Check xmlsec1 library
+#---------------------------------------------
+AM_PATH_XMLSEC1(1.2.10,AC_DEFINE(HAVE_XMLSEC1,1,Define to 1 if you have requested --with-xmlsec1) CFLAGS="$CFLAGS $XMLSEC1_CPPFLAGS"; LDFLAGS="$LDFLAGS $XMLSEC1_LIBS",)
+
AC_OUTPUT(Makefile
libcsoap/Makefile
nanohttp/Makefile