summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar m0gg2006-11-21 08:34:34 +0000
committerGravatar m0gg2006-11-21 08:34:34 +0000
commitcd94b25993049a596b163f0ad8b3a2340e024cc3 (patch)
tree0b9489cf8c5869a2015bc6b1549e1f08f35325e9 /configure.ac
parent949a8d0b46d6baa9f42c2f8c3bd5e3bdc3596cbd (diff)
downloadcsoap-cd94b25993049a596b163f0ad8b3a2340e024cc3.tar.gz
csoap-cd94b25993049a596b163f0ad8b3a2340e024cc3.tar.bz2
Web Services Addressing for multiple transport daemons (initial)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e7433f0..3f49a2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
-AC_INIT(csoap, 1.1.0)
+AC_INIT(csoap, 1.2.0)
AC_CONFIG_SRCDIR([nanohttp/nanohttp-server.c])
AC_CONFIG_SRCDIR([libcsoap/soap-server.c])
@@ -41,7 +41,7 @@ dnl checks for headers
dnl
AC_HEADER_STDC
AC_HEADER_TIME
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h malloc.h netdb.h netinet/in.h stdint.h stdlib.h signal.h pthread.h string.h sys/socket.h sys/time.h unistd.h io.h stdio.h stdarg.h errno.h ctype.h openssl/ssl.h openssl/rand.h openssl/err.h])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h malloc.h netdb.h netinet/in.h stdint.h stdlib.h signal.h pthread.h string.h sys/socket.h time.h sys/time.h unistd.h io.h stdio.h stdarg.h errno.h ctype.h openssl/ssl.h openssl/rand.h openssl/err.h])
dnl
dnl Checks for typedefs, structures, and compiler characteristics.
@@ -63,6 +63,14 @@ AC_FUNC_STRFTIME
AC_FUNC_SELECT_ARGTYPES
AC_CHECK_FUNCS([gethostbyname inet_ntoa memmove memset mkdir select socket strchr strdup strncasecmp strpbrk strspn strstr strtol])
+dnl
+dnl check for uuid
+dnl
+AC_CHECK_HEADERS([uuid.h])
+AC_CHECK_LIB(uuid, uuid_create, [LIBUUID="-luuid"])
+AC_CHECK_FUNCS([uuid_to_string, uuid_create])
+AC_SUBST(LIBUUID)
+
dnl @synopsis ACX_PTHREAD([ACTION-IF-FOUND[, ACTION-IF-NOT-FOUND]])
dnl
dnl @summary figure out how to build C programs using POSIX threads