summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2013-02-17 18:45:45 +0100
committerGravatar Martin Szulecki2013-02-17 18:45:45 +0100
commitf3391275b7807d3523ae15175467d2396af967a3 (patch)
treef327b2e84906230afc0500048d0e6ba3ad70e2ec /configure.ac
parent1f3b90009c3a23f1506a900601874e205224c6aa (diff)
downloadcsoap-f3391275b7807d3523ae15175467d2396af967a3.tar.gz
csoap-f3391275b7807d3523ae15175467d2396af967a3.tar.bz2
Use newer LT_INIT macro and pass -no-undefined for proper DLL generation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7c00430..0ae5f21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@ AC_LANG_C
AC_PROG_CC
AC_PROG_AWK
AC_PROG_INSTALL
-AC_PROG_LIBTOOL
+LT_INIT(win32-dll)
dnl
dnl release and version information
@@ -73,6 +73,17 @@ AC_CHECK_LIB(uuid, uuid_create, [LIBUUID="-luuid"])
AC_CHECK_FUNCS([uuid_to_string, uuid_create])
AC_SUBST(LIBUUID)
+dnl
+dnl check host dependend flags
+dnl
+LIB_EXTRA_LDFLAGS=
+case "$host" in
+ *-*-mingw*|*-*-cygwin*)
+ LIB_EXTRA_LDFLAGS="-no-undefined"
+ ;;
+esac
+AC_SUBST(LIB_EXTRA_LDFLAGS)
+
dnl @synopsis ACX_PTHREAD([ACTION-IF-FOUND[, ACTION-IF-NOT-FOUND]])
dnl
dnl @summary figure out how to build C programs using POSIX threads