summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 32 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 2afb47b..b2f42da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,18 +1,35 @@
-## top directory
-bin_SCRIPTS=csoap-config
-
-#Build in these directories:
-SUBDIRS= $(NANOHTTP_LIBRARY_NAME) $(GENERIC_LIBRARY_NAME) examples
-
-#Distribute these directories:
-DIST_SUBDIRS = $(GENERIC_LIBRARY_NAME)
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libcsoap.pc
-
-
-
-
+SUBDIRS=nanohttp libcsoap examples
+bin_SCRIPTS=csoap-config
+pkgconfigdir=$(libdir)/pkgconfig
+pkgconfig_DATA=libcsoap.pc
+
+m4datadir=$(datadir)/aclocal
+m4data_DATA=libcsoap.m4
+
+documentation=doc/Doxyfile.api \
+ doc/compile.xml \
+ doc/doxygen.css \
+ doc/footer.html \
+ doc/header.html \
+ doc/tutorial.xml \
+ doc/images/logo02.gif
+
+broken_examples=examples/nanohttp/client_get.c \
+ examples/nanohttp/client_mime.c \
+ examples/nanohttp/httpcpost.c \
+ examples/nanohttp/httpget.c \
+ examples/nanohttp/httppost.c \
+ examples/nanohttp/postserver.c \
+ examples/nanohttp/client_post_chunked.c
+
+win32_env=win32/MinGW/Makefile \
+ win32/MinGW/compile.bat \
+ win32/MinGW/config.h \
+ win32/MinGW/readme.txt \
+ win32/include/wsockcompat.h
+
+EXTRA_DIST=$(documentation) $(win32_env) libcsoap.pc.in libcsoap.m4 \
+ $(broken_examples)