summaryrefslogtreecommitdiffstats
path: root/examples/nanohttp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/nanohttp/Makefile.am')
-rw-r--r--examples/nanohttp/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/examples/nanohttp/Makefile.am b/examples/nanohttp/Makefile.am
index 2901d25..dde2691 100644
--- a/examples/nanohttp/Makefile.am
+++ b/examples/nanohttp/Makefile.am
@@ -1,8 +1,8 @@
-bin_PROGRAMS=httpget httpgetcb httppost
+bin_PROGRAMS=httpget httpgetcb httppost httpcpost helloserver
INCLUDES=-I$(top_srcdir)/
LDFLAGS=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION) \
- $(LIBSOCKET) $(LIBNSL)
+ $(LIBSOCKET) $(LIBNSL) -lpthread
httpget_SOURCES=httpget.c
httpget_LDFLAGS=$(LDFLAGS)
@@ -13,6 +13,12 @@ httpgetcb_LDFLAGS=$(LDFLAGS)
httppost_SOURCES=httppost.c
httppost_LDFLAGS=$(LDFLAGS)
+httpcpost_SOURCES=httpcpost.c
+httpcpost_LDFLAGS=$(LDFLAGS)
+
+helloserver_SOURCES=helloserver.c
+helloserver_LDFLAGS=$(LDFLAGS)
+