summaryrefslogtreecommitdiffstats
path: root/examples/nanohttp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/nanohttp/Makefile.am')
-rw-r--r--examples/nanohttp/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/examples/nanohttp/Makefile.am b/examples/nanohttp/Makefile.am
index a5db7b3..221f469 100644
--- a/examples/nanohttp/Makefile.am
+++ b/examples/nanohttp/Makefile.am
@@ -1,13 +1,16 @@
-bin_PROGRAMS=httpget httpgetcb
+bin_PROGRAMS=httpget httpgetcb httppost
+
+INCLUDES=-I$(top_srcdir)/
httpget_SOURCES=httpget.c
-INCLUDES=-I$(top_srcdir)/ $(LIBXML_CFLAGS)
-httpget_LDFLAGS=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION) \
-$(LIBXML_LIBS)
+httpget_LDFLAGS=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION)
httpgetcb_SOURCES=httpgetcb.c
-httpgetcb_LDFLAGS=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION) \
-$(LIBXML_LIBS)
+httpgetcb_LDFLAGS=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION)
+
+httppost_SOURCES=httppost.c
+httppost_LDFLAGS=-L$(top_builddir)/nanohttp -lnanohttp-$(GENERIC_API_VERSION)
+