summaryrefslogtreecommitdiffstats
path: root/nanohttp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nanohttp/Makefile.am')
-rw-r--r--nanohttp/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/nanohttp/Makefile.am b/nanohttp/Makefile.am
index e960f50..dae7909 100644
--- a/nanohttp/Makefile.am
+++ b/nanohttp/Makefile.am
@@ -3,16 +3,20 @@ lib_LTLIBRARIES=libnanohttp.la
libnanohttp_ladir=$(includedir)/nanohttp-@nanohttp_release@/nanohttp
libnanohttp_la_SOURCES=nanohttp-common.c nanohttp-socket.c nanohttp-client.c \
- nanohttp-server.c nanohttp-stream.c nanohttp-mime.c \
- nanohttp-request.c nanohttp-response.c \
- nanohttp-base64.c nanohttp-ssl.c nanohttp-logging.c \
- nanohttp-admin.c nanohttp-error.c
+ nanohttp-server.c nanohttp-stream.c nanohttp-mime.c \
+ nanohttp-request.c nanohttp-response.c nanohttp-base64.c \
+ nanohttp-logging.c nanohttp-admin.c nanohttp-error.c
libnanohttp_la_HEADERS=nanohttp-common.h nanohttp-socket.h nanohttp-client.h \
nanohttp-server.h nanohttp-stream.h nanohttp-mime.h \
nanohttp-request.h nanohttp-response.h \
- nanohttp-base64.h nanohttp-ssl.h nanohttp-logging.h \
- nanohttp-admin.h nanohttp-error.h
+ nanohttp-base64.h nanohttp-logging.h nanohttp-admin.h \
+ nanohttp-error.h
+
+if BUILD_WITH_SSL
+libnanohttp_la_SOURCES+=nanohttp-ssl.c
+libnanohttp_la_HEADERS+=nanohttp-ssl.h
+endif
libnanohttp_la_LDFLAGS= -version-info @nanohttp_version@ -release @nanohttp_release@
libnanohttp_la_CFLAGS=-I${top_srcdir} -D__NHTTP_INTERNAL=1