summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..d42603b
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,22 @@
+TARGET_DIR=$(docdir)
+
+clean-local:
+ cd $(top_srcdir) && rm -rf doc/*.html
+
+install-data-local:
+ installfiles=`echo $(top_srcdir)/doc/*.html`; \
+ if test "$$installfiles" = '$(top_srcdir)/doc/*.html'; \
+ then echo '-- Nothing to install' ; \
+ else \
+ $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR); \
+ for i in $$installfiles; do \
+ echo '-- Installing '$$i ; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
+ done; \
+ fi
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(TARGET_DIR)
+
+DISTCLEANFILES = \
+ Makefile.in