summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2013-09-23 17:59:21 +0200
committerGravatar Martin Szulecki2013-09-23 17:59:21 +0200
commit2614f0a2147ad3a0afc1959da4d16f336b221dde (patch)
treed54cd9eaa63207940f5deab15cfaa916e72cc3fb /configure.ac
parentf025d24826031caac7e448b06a85818d23076486 (diff)
downloadidevicerestore-2614f0a2147ad3a0afc1959da4d16f336b221dde.tar.gz
idevicerestore-2614f0a2147ad3a0afc1959da4d16f336b221dde.tar.bz2
Require autoconf 2.61, add silent rules and configure summary
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 20 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7f32fc8..15ee9ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,11 @@
dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.59)
+AC_PREREQ(2.61)
AC_INIT(idevicerestore, 1.0)
+
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
+
+AC_CONFIG_SRCDIR([src/])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -42,6 +46,19 @@ AC_SUBST(GLOBAL_CFLAGS)
AC_SUBST(AC_LDFLAGS)
AC_SUBST(AC_LDADD)
-AC_CONFIG_FILES(Makefile src/Makefile)
-AC_OUTPUT
+m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+
+AC_OUTPUT([
+Makefile
+src/Makefile
+])
+
+echo "
+Configuration for $PACKAGE $VERSION:
+-------------------------------------------
+
+ Install prefix: .........: $prefix
+ Now type 'make' to build $PACKAGE $VERSION,
+ and then 'make install' for installation.
+"