summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2019-02-14 00:26:25 +0100
committerGravatar Nikias Bassen2019-02-14 00:26:25 +0100
commit64e88489ee47f4e5dca458970688485a0a165c30 (patch)
tree6b54866538be3b62dd4e6b4896920c354787ce42 /configure.ac
parentfbaafdaf87cc01197ad86812a46cf17b7b392b8e (diff)
downloadidevicerestore-64e88489ee47f4e5dca458970688485a0a165c30.tar.gz
idevicerestore-64e88489ee47f4e5dca458970688485a0a165c30.tar.bz2
Allow .ipsw files or extracted IPSW as source
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4c066ea..c9fcb91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,7 +55,8 @@ case ${host_os} in
AC_LDFLAGS+="-static-libgcc"
;;
darwin*)
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([_DARWIN_BETTER_REALPATH], [1], [Use better method for realpath])
AX_PTHREAD([], [AC_MSG_ERROR([pthread is required to build $PACKAGE])])
;;
*)
@@ -65,7 +66,7 @@ case ${host_os} in
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
-AC_CHECK_FUNCS([strsep strcspn mkstemp])
+AC_CHECK_FUNCS([strsep strcspn mkstemp realpath])
if test x$ac_cv_func_strsep != xyes; then
if test x$ac_cv_func_strcspn != xyes; then
AC_MSG_ERROR([You need either strsep or strcspn to build $PACKAGE])