summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2021-11-20 02:55:22 +0100
committerGravatar Nikias Bassen2021-11-20 02:56:10 +0100
commit7377e50e6c05c25fc4d2edfa21f201f6b800d8f1 (patch)
treebe4df4ace57f3415091d8a3ab9ba78c2b2e476f8 /configure.ac
parentedda59e031862e189532c516fa7d40345b89f4f6 (diff)
downloadidevicerestore-7377e50e6c05c25fc4d2edfa21f201f6b800d8f1.tar.gz
idevicerestore-7377e50e6c05c25fc4d2edfa21f201f6b800d8f1.tar.bz2
Update deprecated autoconf macros and update ax_pthread.m4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 15 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 0e412a4..e748924 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,10 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.64)
-AC_INIT([idevicerestore], [1.0.1], [https://github.com/libimobiledevice/idevicerestore/issues],, [https://libimobiledevice.org])
+AC_PREREQ([2.68])
+AC_INIT([idevicerestore],[1.0.1],[https://github.com/libimobiledevice/idevicerestore/issues],[],[https://libimobiledevice.org])
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
@@ -34,7 +34,7 @@ AC_SUBST(OPENSSL_VERSION)
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
-AC_PROG_LIBTOOL
+LT_INIT
# Checks for libraries.
PKG_CHECK_MODULES(libirecovery, libirecovery-1.0 >= $LIBIRECOVERY_VERSION)
@@ -87,32 +87,32 @@ CFLAGS+=" $libimobiledevice_CFLAGS"
# check if libimobiledevice has timeout errors
AC_CACHE_CHECK(for IDEVICE_E_TIMEOUT in enum idevice_error_t, ac_cv_idevice_error_has_timeout,
- AC_TRY_COMPILE([
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <libimobiledevice/libimobiledevice.h>
- ], [
+ ]], [[
return IDEVICE_E_TIMEOUT;
- ], ac_cv_idevice_error_has_timeout=yes, ac_cv_idevice_error_has_timeout=no))
+ ]])],[ac_cv_idevice_error_has_timeout=yes],[ac_cv_idevice_error_has_timeout=no]))
if test "$ac_cv_idevice_error_has_timeout" = "yes"; then
AC_DEFINE(HAVE_IDEVICE_E_TIMEOUT, 1, [Define if enum idevice_error_t defines IDEVICE_E_TIMEOUT])
fi
AC_CACHE_CHECK(for RESTORE_E_RECEIVE_TIMEOUT in enum restored_error_t, ac_cv_restored_error_has_timeout,
- AC_TRY_COMPILE([
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <libimobiledevice/restore.h>
- ], [
+ ]], [[
return RESTORE_E_RECEIVE_TIMEOUT;
- ], ac_cv_restored_error_has_timeout=yes, ac_cv_restored_error_has_timeout=no))
+ ]])],[ac_cv_restored_error_has_timeout=yes],[ac_cv_restored_error_has_timeout=no]))
if test "$ac_cv_restored_error_has_timeout" = "yes"; then
AC_DEFINE(HAVE_RESTORE_E_RECEIVE_TIMEOUT, 1, [Define if enum restored_error_t defines RESTORE_E_RECEIVE_TIMEOUT])
fi
# check if libimobiledevice has enum idevice_connection_type
AC_CACHE_CHECK(for enum idevice_connection_type, ac_cv_enum_idevice_connection_type,
- AC_TRY_COMPILE([
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <libimobiledevice/libimobiledevice.h>
- ], [
+ ]], [[
enum idevice_connection_type conn_type = CONNECTION_USBMUXD;
- ], ac_cv_enum_idevice_connection_type=yes, ac_cv_enum_idevice_connection_type=no))
+ ]])],[ac_cv_enum_idevice_connection_type=yes],[ac_cv_enum_idevice_connection_type=no]))
if (test "$ac_cv_enum_idevice_connection_type" = "yes"); then
AC_DEFINE(HAVE_ENUM_IDEVICE_CONNECTION_TYPE, 1, [Define if enum idevice_connection_type is available])
@@ -155,11 +155,12 @@ AC_SYS_LARGEFILE
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
src/Makefile
docs/Makefile
])
+AC_OUTPUT
echo "
Configuration for $PACKAGE $VERSION: