summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2021-03-17 01:18:53 +0100
committerGravatar Nikias Bassen2021-03-17 01:18:53 +0100
commit798b72b39c16855a2259152e41248ac38496bdde (patch)
tree3511c0aceed440757d40bf6ee311eef919977361 /configure.ac
parent6d3b6bba9127c02fc312468e4174e8148bf87472 (diff)
downloadidevicerestore-798b72b39c16855a2259152e41248ac38496bdde.tar.gz
idevicerestore-798b72b39c16855a2259152e41248ac38496bdde.tar.bz2
configure: Make sure to check endianness
When using macros from endianness.h we want to be sure that the target platform endianness is correctly set. This makes sure that we define the endianness, in case the compiler doesn't provide that information.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 06bb4ed..7df4c15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,10 @@ PKG_CHECK_MODULES(zlib, zlib)
# optional
PKG_CHECK_MODULES(openssl, openssl >= $OPENSSL_VERSION, have_openssl=yes, have_openssl=no)
+# Checking endianness
+AC_C_BIGENDIAN([AC_DEFINE([__BIG_ENDIAN__], [1], [big endian])],
+ [AC_DEFINE([__LITTLE_ENDIAN__], [1], [little endian])])
+
GLOBAL_CFLAGS="-Wno-multichar -O2"
AC_LDADD=""
AC_LDFLAGS=""