summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2020-05-21 04:31:00 +0200
committerGravatar Nikias Bassen2020-05-21 04:31:00 +0200
commit8036f3f227211fdff18cbbf85ab84f45a44c5add (patch)
treeb7cfcdcd02dd31e5483fb338c32839d20543d646 /configure.ac
parentd1cb6bfef6ac8fb08472ac5f1fac93895084371c (diff)
downloadidevicerestore-8036f3f227211fdff18cbbf85ab84f45a44c5add.tar.gz
idevicerestore-8036f3f227211fdff18cbbf85ab84f45a44c5add.tar.bz2
Ignore non-usbmux (i.e. wifi sync) devices in device event callback
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 19 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 030a32b..3a5543c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,9 @@ if test x$ac_cv_func_strsep != xyes; then
fi
fi
+CACHED_CFLAGS="$CFLAGS"
+CFLAGS+=" $libimobiledevice_CFLAGS"
+
# check if libimobiledevice has timeout errors
AC_CACHE_CHECK(for IDEVICE_E_TIMEOUT in enum idevice_error_t, ac_cv_idevice_error_has_timeout,
AC_TRY_COMPILE([
@@ -80,21 +83,35 @@ AC_CACHE_CHECK(for IDEVICE_E_TIMEOUT in enum idevice_error_t, ac_cv_idevice_erro
], [
return IDEVICE_E_TIMEOUT;
], ac_cv_idevice_error_has_timeout=yes, ac_cv_idevice_error_has_timeout=no))
-
if test "$ac_cv_idevice_error_has_timeout" = "yes"; then
AC_DEFINE(HAVE_IDEVICE_E_TIMEOUT, 1, [Define if enum idevice_error_t defines IDEVICE_E_TIMEOUT])
fi
+
AC_CACHE_CHECK(for RESTORE_E_RECEIVE_TIMEOUT in enum restored_error_t, ac_cv_restored_error_has_timeout,
AC_TRY_COMPILE([
#include <libimobiledevice/restore.h>
], [
return RESTORE_E_RECEIVE_TIMEOUT;
], ac_cv_restored_error_has_timeout=yes, ac_cv_restored_error_has_timeout=no))
-
if test "$ac_cv_restored_error_has_timeout" = "yes"; then
AC_DEFINE(HAVE_RESTORE_E_RECEIVE_TIMEOUT, 1, [Define if enum restored_error_t defines RESTORE_E_RECEIVE_TIMEOUT])
fi
+# check if libimobiledevice has enum idevice_connection_type
+AC_CACHE_CHECK(for enum idevice_connection_type, ac_cv_enum_idevice_connection_type,
+ AC_TRY_COMPILE([
+ #include <libimobiledevice/libimobiledevice.h>
+ ], [
+ enum idevice_connection_type conn_type = CONNECTION_USBMUXD;
+ ], ac_cv_enum_idevice_connection_type=yes, ac_cv_enum_idevice_connection_type=no))
+
+if (test "$ac_cv_enum_idevice_connection_type" = "yes"); then
+ AC_DEFINE(HAVE_ENUM_IDEVICE_CONNECTION_TYPE, 1, [Define if enum idevice_connection_type is available])
+fi
+
+CFLAGS="$CACHED_CFLAGS"
+
+
AC_SUBST(GLOBAL_CFLAGS)
AC_SUBST(AC_LDFLAGS)
AC_SUBST(AC_LDADD)