summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2017-02-24 22:10:56 +0100
committerGravatar Nikias Bassen2017-02-24 22:10:56 +0100
commite9c805ffdec34c66fdc751ea222fa40678c71351 (patch)
treecaf4e88914996906434b2547029f8eb2680cbdb4 /configure.ac
parentaaec66651aba5f617c5c2c22b019d115e2db8e8f (diff)
downloadidevicerestore-e9c805ffdec34c66fdc751ea222fa40678c71351.tar.gz
idevicerestore-e9c805ffdec34c66fdc751ea222fa40678c71351.tar.bz2
common: Add strsep() implementation for platforms lacking it
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d36cc67..2b31499 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,13 @@ case "$host_os" in
;;
esac
+AC_CHECK_FUNCS([strsep strcspn])
+if test x$ac_cv_func_strsep != xyes; then
+ if test x$ac_cv_func_strcspn != xyes; then
+ AC_MSG_ERROR([You need either strsep or strcspn to build $PACKAGE])
+ fi
+fi
+
AC_SUBST(GLOBAL_CFLAGS)
AC_SUBST(AC_LDFLAGS)
AC_SUBST(AC_LDADD)