summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Todd Zullinger2009-05-11 15:24:09 -0400
committerGravatar Matt Colyer2009-05-11 20:29:46 -0700
commit9da6bc0c7e9cf7d5d458bbb9d3ef607757f2f48d (patch)
tree357f1397ca251b50a7b258751ae7694e7dd99b3d /configure.ac
parentf3dbc12d4494da2fab11791ab73de60b06e79e8c (diff)
downloadifuse-9da6bc0c7e9cf7d5d458bbb9d3ef607757f2f48d.tar.gz
ifuse-9da6bc0c7e9cf7d5d458bbb9d3ef607757f2f48d.tar.bz2
Fix 'make distcheck'0.9.1
mount.fuse.ifuse needs to be installed in /sbin by default, but this breaks 'make distcheck'. This adds a --disable-root-sbin option to configure and uses it when running 'make distcheck'. Signed-off-by: Matt Colyer <matt@colyer.name>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 684dcce..fdc35ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,4 +34,10 @@ AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
+AC_ARG_ENABLE([root-sbin],
+ AS_HELP_STRING([--disable-root-sbin],
+ [Don't install mount helper in /sbin]),
+ [without_root_sbin=yes],[without_root_sbin=no])
+AM_CONDITIONAL([WITHOUT_ROOT_SBIN], test "x$without_root_sbin" = "xyes")
+
AC_OUTPUT(Makefile src/Makefile fdi/Makefile)