summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2011-01-11 16:58:42 +0100
committerGravatar Martin Szulecki2011-01-12 12:17:34 +0100
commita4554e16960e2112a9b0df7658df53101076a8e9 (patch)
tree6d5cc0c1d8def08ed26813e18d07d21ace96b5d3 /configure.ac
parentade66de829129b1ea9bc1482fa5a10183542795e (diff)
downloadifuse-a4554e16960e2112a9b0df7658df53101076a8e9.tar.gz
ifuse-a4554e16960e2112a9b0df7658df53101076a8e9.tar.bz2
Show a summary as last step of configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b555d8..3ca5b82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,7 @@ PKG_CHECK_MODULES(libimobiledevice11, libimobiledevice-1.0 >= 1.1.0, libimobiled
if test x"$libimobiledevice_1_1" = xyes; then
AC_DEFINE([HAVE_LIBIMOBILEDEVICE_1_1], 1, [Define if libimobiledevice is using 1.1.0 API])
fi
+libimobiledevice_VERSION=`$PKG_CONFIG --modversion "libimobiledevice-1.0" 2>&1`
PKG_CHECK_MODULES(libglib2, glib-2.0 >= 2.14.1)
PKG_CHECK_MODULES(libgthread2, gthread-2.0 >= 2.14.1)
PKG_CHECK_MODULES(libfuse, fuse >= 2.7.0)
@@ -39,3 +40,14 @@ AC_FUNC_REALLOC
AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
AC_OUTPUT(Makefile src/Makefile)
+
+echo "
+Configuration for $PACKAGE $VERSION:
+-------------------------------------------
+
+ Install prefix ..........: $prefix
+ libimobiledevice API ....: $libimobiledevice_VERSION
+
+ Now type 'make' to build $PACKAGE $VERSION,
+ and then 'make install' for installation.
+"