summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 149678b..96d3c7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,12 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = src include
EXTRA_DIST = \
- README.md
+ README.md \
+ git-version-gen
+
+dist-hook:
+ @if ! git diff --quiet; then echo "Uncommitted changes present; not releasing"; exit 1; fi
+ echo $(VERSION) > $(distdir)/.tarball-version
indent:
indent -kr -ut -ts4 -l120 src/*.c src/*.h