diff options
author | 2023-05-07 23:59:43 +0200 | |
---|---|---|
committer | 2023-12-16 00:36:38 +0100 | |
commit | b18bfef130a43219694f67d433ac7776866082f6 (patch) | |
tree | 5fcf7fe6ddd6bcd1d822ca43e56379ee1e591b82 /configure.ac | |
parent | a7f993d45cf1516a2ed6c82fcddd9677984a65c8 (diff) | |
download | libimobiledevice-b18bfef130a43219694f67d433ac7776866082f6.tar.gz libimobiledevice-b18bfef130a43219694f67d433ac7776866082f6.tar.bz2 |
Remove bashisms in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 16 |
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac index 8ba094a..8f24522 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -165,7 +165,7 @@ AC_ARG_WITH([mbedtls], | |||
165 | [Do not look for mbedtls])], | 165 | [Do not look for mbedtls])], |
166 | [use_mbedtls=$withval], | 166 | [use_mbedtls=$withval], |
167 | [use_mbedtls=no]) | 167 | [use_mbedtls=no]) |
168 | if test "x$use_mbedtls" == "xyes"; then | 168 | if test "x$use_mbedtls" = "xyes"; then |
169 | default_openssl=no | 169 | default_openssl=no |
170 | fi | 170 | fi |
171 | AC_ARG_WITH([gnutls], | 171 | AC_ARG_WITH([gnutls], |
@@ -173,7 +173,7 @@ AC_ARG_WITH([gnutls], | |||
173 | [Do not look for GnuTLS])], | 173 | [Do not look for GnuTLS])], |
174 | [use_gnutls=$withval], | 174 | [use_gnutls=$withval], |
175 | [use_gnutls=no]) | 175 | [use_gnutls=no]) |
176 | if test "x$use_gnutls" == "xyes"; then | 176 | if test "x$use_gnutls" = "xyes"; then |
177 | default_openssl=no | 177 | default_openssl=no |
178 | fi | 178 | fi |
179 | AC_ARG_WITH([openssl], | 179 | AC_ARG_WITH([openssl], |
@@ -182,7 +182,7 @@ AC_ARG_WITH([openssl], | |||
182 | [use_openssl=$withval], | 182 | [use_openssl=$withval], |
183 | [use_openssl=$default_openssl]) | 183 | [use_openssl=$default_openssl]) |
184 | 184 | ||
185 | if test "x$use_mbedtls" == "xyes"; then | 185 | if test "x$use_mbedtls" = "xyes"; then |
186 | CACHED_CFLAGS="$CFLAGS" | 186 | CACHED_CFLAGS="$CFLAGS" |
187 | conf_mbedtls_CFLAGS="" | 187 | conf_mbedtls_CFLAGS="" |
188 | if test -n "$mbedtls_INCLUDES"; then | 188 | if test -n "$mbedtls_INCLUDES"; then |
@@ -209,7 +209,7 @@ if test "x$use_mbedtls" == "xyes"; then | |||
209 | ssl_requires="" | 209 | ssl_requires="" |
210 | AC_SUBST(ssl_requires) | 210 | AC_SUBST(ssl_requires) |
211 | else | 211 | else |
212 | if test "x$use_openssl" == "xyes"; then | 212 | if test "x$use_openssl" = "xyes"; then |
213 | pkg_req_openssl="openssl >= 0.9.8" | 213 | pkg_req_openssl="openssl >= 0.9.8" |
214 | PKG_CHECK_MODULES(openssl, $pkg_req_openssl, have_openssl=yes, have_openssl=no) | 214 | PKG_CHECK_MODULES(openssl, $pkg_req_openssl, have_openssl=yes, have_openssl=no) |
215 | if test "x$have_openssl" != "xyes"; then | 215 | if test "x$have_openssl" != "xyes"; then |
@@ -225,7 +225,7 @@ else | |||
225 | AC_SUBST(ssl_requires) | 225 | AC_SUBST(ssl_requires) |
226 | fi | 226 | fi |
227 | else | 227 | else |
228 | if test "x$use_gnutls" == "xyes"; then | 228 | if test "x$use_gnutls" = "xyes"; then |
229 | pkg_req_gnutls="gnutls >= 2.2.0" | 229 | pkg_req_gnutls="gnutls >= 2.2.0" |
230 | pkg_req_libtasn1="libtasn1 >= 1.1" | 230 | pkg_req_libtasn1="libtasn1 >= 1.1" |
231 | PKG_CHECK_MODULES(libgnutls, $pkg_req_gnutls) | 231 | PKG_CHECK_MODULES(libgnutls, $pkg_req_gnutls) |
@@ -246,9 +246,9 @@ else | |||
246 | fi | 246 | fi |
247 | fi | 247 | fi |
248 | fi | 248 | fi |
249 | AM_CONDITIONAL(HAVE_MBEDTLS, test "x$use_mbedtls" == "xyes") | 249 | AM_CONDITIONAL(HAVE_MBEDTLS, test "x$use_mbedtls" = "xyes") |
250 | AM_CONDITIONAL(HAVE_OPENSSL, test "x$use_openssl" == "xyes") | 250 | AM_CONDITIONAL(HAVE_OPENSSL, test "x$use_openssl" = "xyes") |
251 | AM_CONDITIONAL(HAVE_GCRYPT, test "x$use_gnutls" == "xyes") | 251 | AM_CONDITIONAL(HAVE_GCRYPT, test "x$use_gnutls" = "xyes") |
252 | 252 | ||
253 | AC_ARG_ENABLE([wireless-pairing], | 253 | AC_ARG_ENABLE([wireless-pairing], |
254 | [AS_HELP_STRING([--disable-wireless-pairing], | 254 | [AS_HELP_STRING([--disable-wireless-pairing], |