summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Jonathan Beck2008-10-25 17:29:29 +0200
committerGravatar Jonathan Beck2008-10-25 17:31:54 +0200
commit0691e6e4cee6f0e54b432fbf0e478d699e964eaf (patch)
tree3a1b9179aaf5a36b8bfb9472c3b38f7326a430fd /configure.ac
parent113b2250b7d6f075f6b2c3aacae7500ab9f8fb03 (diff)
downloadlibimobiledevice-0691e6e4cee6f0e54b432fbf0e478d699e964eaf.tar.gz
libimobiledevice-0691e6e4cee6f0e54b432fbf0e478d699e964eaf.tar.bz2
add an option to strip off debug code
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c08d10..645b3fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,4 +45,11 @@ AC_ARG_ENABLE([dev-tools],
[build_dev_tools=false])
AM_CONDITIONAL(BUILD_DEV_TOOLS, test x$build_dev_tools = xtrue)
+AC_ARG_ENABLE([debug-code],
+ [AS_HELP_STRING([--enable-debug-code],
+ [enable debug message reporting in library (default is yes)])],
+ [debug_code=true],
+ [debug_code=false])
+AM_CONDITIONAL(STRIP_DEBUG_CODE, test x$debug_code = xfalse)
+
AC_OUTPUT(Makefile src/Makefile include/Makefile fdi/Makefile libiphone-1.0.pc)