summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Jonathan Beck2008-10-25 16:50:28 +0200
committerGravatar Jonathan Beck2008-10-25 16:52:23 +0200
commit113b2250b7d6f075f6b2c3aacae7500ab9f8fb03 (patch)
tree86f07cb376d224bc72d482ff162c527a77474b3d /configure.ac
parent0b2cfd2c7c6211ff5902e48720c34067f238ce90 (diff)
downloadlibimobiledevice-113b2250b7d6f075f6b2c3aacae7500ab9f8fb03.tar.gz
libimobiledevice-113b2250b7d6f075f6b2c3aacae7500ab9f8fb03.tar.bz2
add configure options to control building of development tools
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7fc417c..2c08d10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,4 +38,11 @@ AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
+AC_ARG_ENABLE([dev-tools],
+ [AS_HELP_STRING([--enable-dev-tools],
+ [build development helper tools (default is no)])],
+ [build_dev_tools=true],
+ [build_dev_tools=false])
+AM_CONDITIONAL(BUILD_DEV_TOOLS, test x$build_dev_tools = xtrue)
+
AC_OUTPUT(Makefile src/Makefile include/Makefile fdi/Makefile libiphone-1.0.pc)