summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2012-03-20 22:59:26 +0100
committerGravatar Martin Szulecki2012-03-20 22:59:26 +0100
commit11b93e83df1bdae1277d8059e25ef2344fed8706 (patch)
tree52790cbd5bbbaec122629ee0f95cf997d6b270eb /configure.ac
parentba0519da1f6d406a0baf6c33134fdd279f5f28dd (diff)
downloadlibimobiledevice-11b93e83df1bdae1277d8059e25ef2344fed8706.tar.gz
libimobiledevice-11b93e83df1bdae1277d8059e25ef2344fed8706.tar.bz2
Use AC_LANG_SOURCE to avoid warnings in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index af70dd2..7dcf87b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,11 +172,11 @@ if test "$enable_largefile" != no; then
LFS_CFLAGS="$LFS_CFLAGS -D_FILE_OFFSET_BITS=$ac_cv_sys_file_offset_bits"
else
AC_MSG_CHECKING(for native large file support)
- AC_RUN_IFELSE([#include <unistd.h>
+ AC_RUN_IFELSE([AC_LANG_SOURCE([#include <unistd.h>
int main (int argc, char **argv)
{
exit(!(sizeof(off_t) == 8));
- }],
+ }])],
[ac_cv_sys_file_offset_bits=64; AC_DEFINE(_FILE_OFFSET_BITS,64)
AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)])