summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2013-09-27 13:13:15 +0200
committerGravatar Nikias Bassen2013-09-27 13:13:15 +0200
commitb9fecbe1c6e24be29ff510d7128763b900147416 (patch)
tree77681d506ebae760562b57e30c3402eeea0b17e4 /configure.ac
parent494ff699d6754661e86a96707940d27c652816ca (diff)
downloadlibimobiledevice-b9fecbe1c6e24be29ff510d7128763b900147416.tar.gz
libimobiledevice-b9fecbe1c6e24be29ff510d7128763b900147416.tar.bz2
configure.ac: add -fsigned-char to make sure char is signed
on systems like the Raspberry Pi char is unsigned by default but our code expects char to be signed. So we should be good with -fsigned-char
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 77ac1c2..5711659 100644
--- a/configure.ac
+++ b/configure.ac
@@ -188,7 +188,7 @@ else
building_debug_code=yes
fi
-AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter")
+AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -fsigned-char")
AC_SUBST(GLOBAL_CFLAGS)
# check for large file support