summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2019-06-10 04:11:43 +0200
committerGravatar Nikias Bassen2019-06-10 04:11:43 +0200
commiteb61c7b660fb58f9edb0f7b5507ebaad28422361 (patch)
tree8064e2b195bd9d3110e9a199a510c46d4190c35a /configure.ac
parent4727a86940875ab6f55cd0ddb7be99a705686f53 (diff)
downloadlibimobiledevice-eb61c7b660fb58f9edb0f7b5507ebaad28422361.tar.gz
libimobiledevice-eb61c7b660fb58f9edb0f7b5507ebaad28422361.tar.bz2
configure.ac: Fix --without-cython/--with-cython logic
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 69ff13b..a2a5b12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,17 +66,17 @@ if test "x$ac_cv_have_endian_h" = "xno"; then
fi
# Check for operating system
-AC_MSG_CHECKING([whether we need platform-specific build settings])
+AC_MSG_CHECKING([for platform-specific build settings])
case ${host_os} in
*mingw32*|*cygwin*)
- AC_MSG_RESULT([yes])
+ AC_MSG_RESULT([${host_os}])
win32=true
;;
darwin*)
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([${host_os}])
;;
*)
- AC_MSG_RESULT([yes])
+ AC_MSG_RESULT([${host_os}])
AX_PTHREAD([], [AC_MSG_ERROR([pthread is required to build $PACKAGE_NAME])])
AC_CHECK_LIB(pthread, [pthread_once], [], [AC_MSG_ERROR([pthread with pthread_once required to build $PACKAGE_NAME])])
;;
@@ -89,9 +89,9 @@ AC_CHECK_MEMBER(struct dirent.d_type, AC_DEFINE(HAVE_DIRENT_D_TYPE, 1, [define i
AC_ARG_WITH([cython],
[AS_HELP_STRING([--without-cython],
[build Python bindings using Cython (default is yes)])],
- [build_cython=false],
- [build_cython=true])
-if test "$build_cython" = "true"; then
+ [build_cython=$withval],
+ [build_cython=yes])
+if test "$build_cython" = "yes"; then
AM_PATH_PYTHON(2.3)
AC_PROG_CYTHON(0.17.0)
CYTHON_PYTHON