summaryrefslogtreecommitdiffstats
path: root/cython/Makefile.am
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2012-03-21 14:52:55 +0100
committerGravatar Martin Szulecki2012-03-21 14:52:55 +0100
commit103694072082ee7d55b134d7dad3084200e38871 (patch)
tree0cd345849d4ea746a34c04bf08a5d56ab352815e /cython/Makefile.am
parenta81bc7e8c36219270e2218861ffa0db7c1d8d77b (diff)
downloadlibimobiledevice-103694072082ee7d55b134d7dad3084200e38871.tar.gz
libimobiledevice-103694072082ee7d55b134d7dad3084200e38871.tar.bz2
cython: Silence a couple of warnings when generating bindings with Cython
The Cython team apparently does not care a lot about polishing warnings out, thus we have to supress them here or it looks really ugly.
Diffstat (limited to 'cython/Makefile.am')
-rw-r--r--cython/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cython/Makefile.am b/cython/Makefile.am
index 16b464e..ae10b06 100644
--- a/cython/Makefile.am
+++ b/cython/Makefile.am
@@ -30,7 +30,7 @@ EXTRA_DIST = imobiledevice.pyx imobiledevice.pxd $(PXIINCLUDES)
imobiledevicedir = $(pyexecdir)
imobiledevice_LTLIBRARIES = imobiledevice.la
imobiledevice_la_SOURCES = imobiledevice.pyx
-imobiledevice_la_CFLAGS = -I../include -I../src $(PYTHON_CPPFLAGS) $(AM_CFLAGS)
+imobiledevice_la_CFLAGS = -I../include -I../src $(PYTHON_CPPFLAGS) $(AM_CFLAGS) -Wno-shadow -Wno-redundant-decls -Wno-switch-default -Wno-strict-aliasing -Wno-implicit-function-declaration
imobiledevice_la_LDFLAGS = -module -avoid-version -L$(libdir) $(PYTHON_LDFLAGS) $(AM_LDFLAGS)
imobiledevice_la_LIBADD = ../src/libimobiledevice.la