summaryrefslogtreecommitdiffstats
path: root/cython/Makefile.am
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2020-06-04 03:31:12 +0200
committerGravatar Martin Szulecki2020-06-04 03:31:12 +0200
commitc3c01b4bd500a467627a8892ff41a46b3b03be2b (patch)
treed86418bf8efe07490b56afa17fd01e720263196e /cython/Makefile.am
parent2e937857c1b7799fd6d8da04c474abed1b138294 (diff)
downloadlibimobiledevice-c3c01b4bd500a467627a8892ff41a46b3b03be2b.tar.gz
libimobiledevice-c3c01b4bd500a467627a8892ff41a46b3b03be2b.tar.bz2
cython: Add "-Wno-cast-function-type" flag to silence warnings with GCC 8+
Diffstat (limited to 'cython/Makefile.am')
-rw-r--r--cython/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cython/Makefile.am b/cython/Makefile.am
index 6aeaf08..4dbd6fa 100644
--- a/cython/Makefile.am
+++ b/cython/Makefile.am
@@ -37,7 +37,7 @@ EXTRA_DIST = imobiledevice.pyx imobiledevice.pxd $(PXIINCLUDES)
imobiledevicedir = $(pyexecdir)
imobiledevice_LTLIBRARIES = imobiledevice.la
imobiledevice_la_SOURCES = imobiledevice.pyx
-imobiledevice_la_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src $(PYTHON_CPPFLAGS) $(AM_CFLAGS) -Wno-shadow -Wno-redundant-decls -Wno-switch-default -Wno-strict-aliasing -Wno-implicit-function-declaration -fvisibility=default
+imobiledevice_la_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src $(PYTHON_CPPFLAGS) $(AM_CFLAGS) -Wno-shadow -Wno-redundant-decls -Wno-switch-default -Wno-strict-aliasing -Wno-implicit-function-declaration -Wno-cast-function-type -fvisibility=default
imobiledevice_la_LDFLAGS = -module -avoid-version -L$(libdir) $(PYTHON_LIBS) $(AM_LIBS) -no-undefined
imobiledevice_la_LIBADD = $(top_builddir)/src/libimobiledevice.la