summaryrefslogtreecommitdiffstats
path: root/swig/Makefile.am
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2009-12-10 18:40:08 +0100
committerGravatar Martin Szulecki2009-12-10 18:40:08 +0100
commit7b153ef8ca43c4b437cb9e4e6f2777bdb7047677 (patch)
tree04472b547ed5363dc1d6d4b9c4766823683ebc9d /swig/Makefile.am
parent444b4d94afa6ff15129922f0dc2b82ae69deeac8 (diff)
parent318cc4f7b336109819c7b4c6a1a9f2e8d37d9bed (diff)
downloadlibimobiledevice-7b153ef8ca43c4b437cb9e4e6f2777bdb7047677.tar.gz
libimobiledevice-7b153ef8ca43c4b437cb9e4e6f2777bdb7047677.tar.bz2
Merge branch 'master' of git://github.com/MattColyer/libiphone into martin
Diffstat (limited to 'swig/Makefile.am')
-rw-r--r--swig/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/swig/Makefile.am b/swig/Makefile.am
index a38534d..ef87733 100644
--- a/swig/Makefile.am
+++ b/swig/Makefile.am
@@ -1,5 +1,6 @@
INCLUDES = -I$(top_srcdir)/include $(libplist_CFLAGS) $(SWIG_PYTHON_CPPFLAGS) -I$(oldincludedir)
+if HAVE_SWIG
BUILT_SOURCES = iphone_wrap.cxx
SWIG_SOURCES = iphone.i
@@ -29,3 +30,5 @@ _iphone_la_LIBADD = $(top_builddir)/src/libiphone.la $(libplistmm_LIBS)
iphone_wrap.cxx : $(SWIG_SOURCES)
$(SWIG) $(SWIG_PYTHON_OPT) $(INCLUDES) -I$(top_srcdir)/src -o $@ $<
+endif # HAVE_SWIG
+