summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2023-12-30 01:27:42 +0100
committerGravatar Nikias Bassen2023-12-30 01:27:42 +0100
commit7f781eb61215c84bd0f79838fbcb5efd66121677 (patch)
tree2741401eec23b6504e068d8640f2ac9237e3795e /tools/Makefile.am
parent76f924c2a1c61d05ece9bdc699a350ad165e3761 (diff)
downloadlibimobiledevice-7f781eb61215c84bd0f79838fbcb5efd66121677.tar.gz
libimobiledevice-7f781eb61215c84bd0f79838fbcb5efd66121677.tar.bz2
tools: Add afcclient utility
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index bd93631..4cac1fc 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -31,7 +31,8 @@ bin_PROGRAMS = \
31 idevicedevmodectl \ 31 idevicedevmodectl \
32 idevicenotificationproxy \ 32 idevicenotificationproxy \
33 idevicecrashreport \ 33 idevicecrashreport \
34 idevicesetlocation 34 idevicesetlocation \
35 afcclient
35 36
36idevicebtlogger_SOURCES = idevicebtlogger.c 37idevicebtlogger_SOURCES = idevicebtlogger.c
37iidevicebtlogger_CFLAGS = $(AM_CFLAGS) 38iidevicebtlogger_CFLAGS = $(AM_CFLAGS)
@@ -132,3 +133,12 @@ idevicesetlocation_SOURCES = idevicesetlocation.c
132idevicesetlocation_CFLAGS = $(AM_CFLAGS) 133idevicesetlocation_CFLAGS = $(AM_CFLAGS)
133idevicesetlocation_LDFLAGS = $(AM_LDFLAGS) 134idevicesetlocation_LDFLAGS = $(AM_LDFLAGS)
134idevicesetlocation_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la 135idevicesetlocation_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
136
137afcclient_SOURCES = afcclient.c
138afcclient_CFLAGS = $(AM_CFLAGS)
139afcclient_LDFLAGS = $(AM_LDFLAGS)
140if HAVE_READLINE
141 afcclient_CFLAGS += $(readline_CFLAGS)
142 afcclient_LDFLAGS += $(readline_LIBS)
143endif
144afcclient_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(limd_glue_LIBS)