summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGravatar Geoffrey Kruse2021-03-06 16:56:54 -0800
committerGravatar Nikias Bassen2022-05-05 18:53:16 +0200
commita070a2e0b8774132a2c90822ba22580c4d1842da (patch)
treeae4dfcdacb2401c42029f56b1ea831afff2f71e9 /tools/Makefile.am
parentc6f89deac00347faa187f2f5296e32840c4f26b4 (diff)
downloadlibimobiledevice-a070a2e0b8774132a2c90822ba22580c4d1842da.tar.gz
libimobiledevice-a070a2e0b8774132a2c90822ba22580c4d1842da.tar.bz2
Initial commit of working packet logger (idevicebtlogger)
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 4740330..d701bab 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -11,6 +11,7 @@ AM_LDFLAGS = \
$(libplist_LIBS)
bin_PROGRAMS = \
+ idevicebtlogger\
idevice_id \
ideviceinfo \
idevicename \
@@ -30,6 +31,11 @@ bin_PROGRAMS = \
idevicecrashreport \
idevicesetlocation
+idevicebtlogger_SOURCES = idevicebtlogger.c
+iidevicebtlogger_CFLAGS = $(AM_CFLAGS)
+idevicebtlogger_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) -lpcap
+idevicebtlogger_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
+
ideviceinfo_SOURCES = ideviceinfo.c
ideviceinfo_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS)
ideviceinfo_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS)