summaryrefslogtreecommitdiffstats
path: root/3rd_party/ed25519/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rd_party/ed25519/Makefile.am')
-rw-r--r--3rd_party/ed25519/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/3rd_party/ed25519/Makefile.am b/3rd_party/ed25519/Makefile.am
new file mode 100644
index 0000000..d8e4e04
--- /dev/null
+++ b/3rd_party/ed25519/Makefile.am
@@ -0,0 +1,26 @@
1AUTOMAKE_OPTIONS = foreign no-dependencies
2
3AM_CPPFLAGS = \
4 -I$(top_srcdir)/include \
5 -I$(top_srcdir)
6
7AM_CFLAGS = \
8 $(GLOBAL_CFLAGS) \
9 $(ssl_lib_CFLAGS)
10
11AM_LDFLAGS =
12
13noinst_LTLIBRARIES = libed25519.la
14libed25519_la_LIBADD =
15libed25519_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined
16libed25519_la_SOURCES = \
17 add_scalar.c \
18 fe.c \
19 ge.c \
20 keypair.c \
21 key_exchange.c \
22 sc.c \
23 seed.c \
24 sign.c \
25 sha512.c \
26 verify.c