summaryrefslogtreecommitdiffstats
path: root/3rd_party/libsrp6a-sha512/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rd_party/libsrp6a-sha512/Makefile.am')
-rw-r--r--3rd_party/libsrp6a-sha512/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/3rd_party/libsrp6a-sha512/Makefile.am b/3rd_party/libsrp6a-sha512/Makefile.am
new file mode 100644
index 0000000..2acd582
--- /dev/null
+++ b/3rd_party/libsrp6a-sha512/Makefile.am
@@ -0,0 +1,31 @@
1AUTOMAKE_OPTIONS = foreign no-dependencies
2
3AM_CPPFLAGS = \
4 -I$(top_srcdir)/include \
5 -I$(top_srcdir) \
6 -Wno-incompatible-pointer-types
7
8AM_CFLAGS = -DHAVE_CONFIG_H
9if HAVE_OPENSSL
10AM_CFLAGS += -DOPENSSL=1 $(openssl_CFLAGS)
11else
12if HAVE_GCRYPT
13AM_CFLAGS += -DGCRYPT=1 $(libgcrypt_CFLAGS)
14else
15if HAVE_MBEDTLS
16AM_CFLAGS += -DMBEDTLS=1 $(mbedtls_CFLAGS)
17endif
18endif
19endif
20
21noinst_LTLIBRARIES = libsrp6a-sha512.la
22
23libsrp6a_sha512_la_SOURCES = \
24 t_conv.c t_math.c t_misc.c \
25 t_truerand.c cstr.c \
26 srp.c srp6a_sha512_client.c \
27 srp.h srp_aux.h cstr.h \
28 t_sha.c
29#if !HAVE_OPENSSL
30#libsrp6a_sha512_la_SOURCES += t_sha.c
31#endif