summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..ba7ed9c
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,29 @@
1AM_CPPFLAGS = \
2 -I$(top_srcdir)/include \
3 -I$(top_srcdir)
4
5AM_CFLAGS = \
6 $(GLOBAL_CFLAGS) \
7 $(ssl_lib_CFLAGS) \
8 $(LFS_CFLAGS) \
9 $(libusbmuxd_CFLAGS) \
10 $(limd_glue_CFLAGS) \
11 $(libplist_CFLAGS)
12
13AM_LDFLAGS = \
14 $(ssl_lib_LIBS) \
15 ${libpthread_LIBS} \
16 $(libusbmuxd_LIBS) \
17 $(limd_glue_LIBS) \
18 $(libplist_LIBS)
19
20noinst_LTLIBRARIES = libinternalcommon.la
21libinternalcommon_la_LIBADD =
22libinternalcommon_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined
23libinternalcommon_la_SOURCES = \
24 debug.c debug.h \
25 userpref.c userpref.h
26
27if WIN32
28libinternalcommon_la_LIBADD += -lole32 -lws2_32
29endif