summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c08d10..645b3fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,4 +45,11 @@ AC_ARG_ENABLE([dev-tools],
[build_dev_tools=false])
AM_CONDITIONAL(BUILD_DEV_TOOLS, test x$build_dev_tools = xtrue)
+AC_ARG_ENABLE([debug-code],
+ [AS_HELP_STRING([--enable-debug-code],
+ [enable debug message reporting in library (default is yes)])],
+ [debug_code=true],
+ [debug_code=false])
+AM_CONDITIONAL(STRIP_DEBUG_CODE, test x$debug_code = xfalse)
+
AC_OUTPUT(Makefile src/Makefile include/Makefile fdi/Makefile libiphone-1.0.pc)