summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 24eec9b..286b1d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,13 +43,20 @@ AC_ARG_ENABLE([dev-tools],
[build development helper tools (default is no)])],
[build_dev_tools=true],
[build_dev_tools=false])
-AM_CONDITIONAL([BUILD_DEV_TOOLS], [test x$build_dev_tools = xtrue])
+if test "$build_dev_tools" = true; then
+ DEV_SUB=dev
+else
+ DEV_SUB=
+fi
+AC_SUBST([DEV_SUB])
AC_ARG_ENABLE([debug-code],
- [AS_HELP_STRING([--enable-debug-code],
- [enable debug message reporting in library (default is yes)])],
- [debug_code=true],
- [debug_code=false])
-AM_CONDITIONAL([STRIP_DEBUG_CODE], [test x$debug_code = xfalse])
-
-AC_OUTPUT(Makefile src/Makefile include/Makefile fdi/Makefile libiphone-1.0.pc)
+ [AS_HELP_STRING([--disable-debug-code],
+ [disable debug message reporting in library (default is yes)])],
+ [no_debug_code=false],
+ [no_debug_code=true])
+if test "$no_debug_code" = true; then
+ AC_DEFINE(STRIP_DEBUG_CODE,1,[Strip debug reporting code])
+fi
+
+AC_OUTPUT(Makefile src/Makefile include/Makefile fdi/Makefile dev/Makefile libiphone-1.0.pc)