summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am89
1 files changed, 67 insertions, 22 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 70dc895..58cf07c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,24 +1,69 @@
1AM_CPPFLAGS = -I$(top_srcdir)/include 1AM_CPPFLAGS = \
2 -I$(top_srcdir)/include \
3 -I$(top_srcdir)/3rd_party/libsrp6a-sha512 \
4 -I$(top_srcdir)/3rd_party/ed25519 \
5 -I$(top_srcdir)
2 6
3AM_CFLAGS = $(GLOBAL_CFLAGS) $(libusbmuxd_CFLAGS) $(libglib2_CFLAGS) $(libgnutls_CFLAGS) $(libtasn1_CFLAGS) $(libgthread2_CFLAGS) $(libplist_CFLAGS) $(LFS_CFLAGS) 7AM_CFLAGS = \
4AM_LDFLAGS = $(libglib2_LIBS) $(libgnutls_LIBS) $(libtasn1_LIBS) $(libgthread2_LIBS) $(libplist_LIBS) $(libusbmuxd_LIBS) $(libgcrypt_LIBS) 8 $(GLOBAL_CFLAGS) \
9 $(ssl_lib_CFLAGS) \
10 $(LFS_CFLAGS) \
11 $(PTHREAD_CFLAGS) \
12 $(libusbmuxd_CFLAGS) \
13 $(libplist_CFLAGS) \
14 $(limd_glue_CFLAGS)
5 15
6lib_LTLIBRARIES = libimobiledevice.la 16AM_LDFLAGS = \
7libimobiledevice_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LIBIMOBILEDEVICE_SO_VERSION) -no-undefined 17 $(ssl_lib_LIBS) \
8libimobiledevice_la_SOURCES = idevice.c idevice.h \ 18 $(PTHREAD_LIBS) \
9 debug.c debug.h\ 19 $(libusbmuxd_LIBS) \
10 userpref.c userpref.h\ 20 $(libplist_LIBS) \
11 property_list_service.c property_list_service.h\ 21 $(limd_glue_LIBS)
12 device_link_service.c device_link_service.h\ 22
13 lockdown.c lockdown.h\ 23lib_LTLIBRARIES = libimobiledevice-1.0.la
14 afc.c afc.h\ 24libimobiledevice_1_0_la_LIBADD = $(top_builddir)/common/libinternalcommon.la
15 file_relay.c file_relay.h\ 25if HAVE_WIRELESS_PAIRING
16 notification_proxy.c notification_proxy.h\ 26libimobiledevice_1_0_la_LIBADD += $(top_builddir)/3rd_party/ed25519/libed25519.la $(top_builddir)/3rd_party/libsrp6a-sha512/libsrp6a-sha512.la
17 installation_proxy.c installation_proxy.h\ 27endif
18 sbservices.c sbservices.h\ 28libimobiledevice_1_0_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LIBIMOBILEDEVICE_SO_VERSION) -no-undefined
19 mobile_image_mounter.c mobile_image_mounter.h\ 29if DARWIN
20 screenshotr.c screenshotr.h\ 30libimobiledevice_1_0_la_LDFLAGS += -framework CoreFoundation -framework SystemConfiguration
21 mobilesync.c mobilesync.h\ 31endif
22 mobilebackup.c mobilebackup.h\ 32libimobiledevice_1_0_la_SOURCES = \
23 house_arrest.c house_arrest.h\ 33 idevice.c idevice.h \
24 restore.c restore.h 34 service.c service.h \
35 property_list_service.c property_list_service.h \
36 device_link_service.c device_link_service.h \
37 lockdown.c lockdown.h \
38 lockdown-cu.c \
39 afc.c afc.h \
40 file_relay.c file_relay.h \
41 notification_proxy.c notification_proxy.h \
42 installation_proxy.c installation_proxy.h \
43 sbservices.c sbservices.h \
44 mobile_image_mounter.c mobile_image_mounter.h \
45 screenshotr.c screenshotr.h \
46 mobilesync.c mobilesync.h \
47 mobilebackup.c mobilebackup.h \
48 house_arrest.c house_arrest.h \
49 mobilebackup2.c mobilebackup2.h \
50 misagent.c misagent.h \
51 restore.c restore.h \
52 diagnostics_relay.c diagnostics_relay.h \
53 heartbeat.c heartbeat.h \
54 debugserver.c debugserver.h \
55 webinspector.c webinspector.h \
56 mobileactivation.c mobileactivation.h \
57 preboard.c preboard.h \
58 companion_proxy.c companion_proxy.h \
59 reverse_proxy.c reverse_proxy.h \
60 syslog_relay.c syslog_relay.h \
61 bt_packet_logger.c bt_packet_logger.h
62
63if WIN32
64libimobiledevice_1_0_la_LDFLAGS += -avoid-version -static-libgcc
65libimobiledevice_1_0_la_LIBADD += -lole32 -lws2_32 -lgdi32
66endif
67
68pkgconfigdir = $(libdir)/pkgconfig
69pkgconfig_DATA = libimobiledevice-1.0.pc