summaryrefslogtreecommitdiffstats
path: root/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'swig/Makefile.am')
-rw-r--r--swig/Makefile.am34
1 files changed, 0 insertions, 34 deletions
diff --git a/swig/Makefile.am b/swig/Makefile.am
deleted file mode 100644
index 8c1f2b9..0000000
--- a/swig/Makefile.am
+++ /dev/null
@@ -1,34 +0,0 @@
1AM_CPPFLAGS = -I$(top_srcdir)/include $(libglib2_CFLAGS) $(libplist_CFLAGS) $(SWIG_PYTHON_CPPFLAGS) -I$(oldincludedir)
2
3if HAVE_SWIG
4BUILT_SOURCES = imobiledevice_wrap.cxx
5SWIG_SOURCES = imobiledevice.i
6
7CLEANFILES = \
8 *.pyc \
9 *.pyo \
10 _imobiledevice.so \
11 imobiledevice.py \
12 imobiledevice_wrap.cxx
13
14EXTRA_DIST = \
15 __init__.py \
16 imobiledevice.i
17
18swigincludedir =$(includedir)/libimobiledevice/swig
19swiginclude_HEADERS = $(SWIG_SOURCES)
20
21imobiledevicedir = $(pyexecdir)/imobiledevice
22imobiledevice_PYTHON = __init__.py
23nodist_imobiledevice_PYTHON = imobiledevice.py
24imobiledevice_LTLIBRARIES = _imobiledevice.la
25nodist__imobiledevice_la_SOURCES = imobiledevice_wrap.cxx $(SWIG_SOURCES)
26_imobiledevice_la_CFLAGS = $(PYTHON_CPPFLAGS) -I$(top_srcdir)/src
27_imobiledevice_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS)
28_imobiledevice_la_LIBADD = $(top_builddir)/src/libimobiledevice.la $(libplistmm_LIBS)
29
30imobiledevice_wrap.cxx : $(SWIG_SOURCES)
31 $(SWIG) $(SWIG_PYTHON_OPT) $(AM_CPPFLAGS) -I$(top_srcdir)/src -o $@ $<
32
33endif # HAVE_SWIG
34