summaryrefslogtreecommitdiffstats
path: root/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'swig/Makefile.am')
-rw-r--r--swig/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/swig/Makefile.am b/swig/Makefile.am
index ef87733..6852aad 100644
--- a/swig/Makefile.am
+++ b/swig/Makefile.am
@@ -1,33 +1,33 @@
INCLUDES = -I$(top_srcdir)/include $(libplist_CFLAGS) $(SWIG_PYTHON_CPPFLAGS) -I$(oldincludedir)
if HAVE_SWIG
-BUILT_SOURCES = iphone_wrap.cxx
-SWIG_SOURCES = iphone.i
+BUILT_SOURCES = imobiledevice_wrap.cxx
+SWIG_SOURCES = imobiledevice.i
CLEANFILES = \
*.pyc \
*.pyo \
- _iphone.so \
- iphone.py \
- iphone_wrap.cxx
+ _imobiledevice.so \
+ imobiledevice.py \
+ imobiledevice_wrap.cxx
EXTRA_DIST = \
__init__.py \
- iphone.i
+ imobiledevice.i
-swigincludedir =$(includedir)/libiphone/swig
+swigincludedir =$(includedir)/libimobiledevice/swig
swiginclude_HEADERS = $(SWIG_SOURCES)
-iphonedir = $(pyexecdir)/iphone
-iphone_PYTHON = __init__.py
-nodist_iphone_PYTHON = iphone.py
-iphone_LTLIBRARIES = _iphone.la
-nodist__iphone_la_SOURCES = iphone_wrap.cxx $(SWIG_SOURCES)
-_iphone_la_CFLAGS = $(PYTHON_CPPFLAGS) -I$(top_srcdir)/src
-_iphone_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS)
-_iphone_la_LIBADD = $(top_builddir)/src/libiphone.la $(libplistmm_LIBS)
+imobiledevicedir = $(pyexecdir)/imobiledevice
+imobiledevice_PYTHON = __init__.py
+nodist_imobiledevice_PYTHON = imobiledevice.py
+imobiledevice_LTLIBRARIES = _imobiledevice.la
+nodist__imobiledevice_la_SOURCES = imobiledevice_wrap.cxx $(SWIG_SOURCES)
+_imobiledevice_la_CFLAGS = $(PYTHON_CPPFLAGS) -I$(top_srcdir)/src
+_imobiledevice_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS)
+_imobiledevice_la_LIBADD = $(top_builddir)/src/libimobiledevice.la $(libplistmm_LIBS)
-iphone_wrap.cxx : $(SWIG_SOURCES)
+imobiledevice_wrap.cxx : $(SWIG_SOURCES)
$(SWIG) $(SWIG_PYTHON_OPT) $(INCLUDES) -I$(top_srcdir)/src -o $@ $<
endif # HAVE_SWIG