diff options
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r-- | tools/Makefile.am | 139 |
1 files changed, 116 insertions, 23 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am index 0a47fdc..b0c2769 100644 --- a/tools/Makefile.am +++ b/tools/Makefile.am | |||
@@ -1,51 +1,144 @@ | |||
1 | AM_CPPFLAGS = -I$(top_srcdir)/include | 1 | AM_CPPFLAGS = \ |
2 | -I$(top_srcdir)/include \ | ||
3 | -I$(top_srcdir) | ||
2 | 4 | ||
3 | AM_CFLAGS = $(GLOBAL_CFLAGS) $(libglib2_CFLAGS) $(libgnutls_CFLAGS) $(libtasn1_CFLAGS) $(libgthread2_CFLAGS) $(LFS_CFLAGS) | 5 | AM_CFLAGS = \ |
4 | AM_LDFLAGS = $(libglib2_LIBS) $(libgnutls_LIBS) $(libtasn1_LIBS) $(libgthread2_LIBS) | 6 | $(GLOBAL_CFLAGS) \ |
7 | $(ssl_lib_CFLAGS) \ | ||
8 | $(libplist_CFLAGS) \ | ||
9 | $(LFS_CFLAGS) | ||
5 | 10 | ||
6 | bin_PROGRAMS = idevice_id ideviceinfo idevicepair idevicesyslog idevicebackup ideviceimagemounter idevicescreenshot ideviceenterrecovery idevicedate | 11 | AM_LDFLAGS = \ |
12 | $(libplist_LIBS) | ||
13 | |||
14 | bin_PROGRAMS = \ | ||
15 | idevicebtlogger\ | ||
16 | idevice_id \ | ||
17 | ideviceinfo \ | ||
18 | idevicename \ | ||
19 | idevicepair \ | ||
20 | idevicesyslog \ | ||
21 | ideviceimagemounter \ | ||
22 | idevicescreenshot \ | ||
23 | ideviceenterrecovery \ | ||
24 | idevicedate \ | ||
25 | idevicebackup \ | ||
26 | idevicebackup2 \ | ||
27 | ideviceprovision \ | ||
28 | idevicedebugserverproxy \ | ||
29 | idevicediagnostics \ | ||
30 | idevicedebug \ | ||
31 | idevicedevmodectl \ | ||
32 | idevicenotificationproxy \ | ||
33 | idevicecrashreport \ | ||
34 | idevicesetlocation \ | ||
35 | afcclient | ||
36 | |||
37 | idevicebtlogger_SOURCES = idevicebtlogger.c | ||
38 | idevicebtlogger_CFLAGS = $(AM_CFLAGS) | ||
39 | idevicebtlogger_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) | ||
40 | idevicebtlogger_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
7 | 41 | ||
8 | ideviceinfo_SOURCES = ideviceinfo.c | 42 | ideviceinfo_SOURCES = ideviceinfo.c |
9 | ideviceinfo_CFLAGS = $(AM_CFLAGS) | 43 | ideviceinfo_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) |
10 | ideviceinfo_LDFLAGS = $(AM_LDFLAGS) | 44 | ideviceinfo_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) |
11 | ideviceinfo_LDADD = ../src/libimobiledevice.la | 45 | ideviceinfo_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la |
46 | |||
47 | idevicename_SOURCES = idevicename.c | ||
48 | idevicename_CFLAGS = $(AM_CFLAGS) | ||
49 | idevicename_LDFLAGS = $(AM_LDFLAGS) | ||
50 | idevicename_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
12 | 51 | ||
13 | idevicepair_SOURCES = idevicepair.c | 52 | idevicepair_SOURCES = idevicepair.c |
14 | idevicepair_CFLAGS = $(AM_CFLAGS) -I$(top_srcdir)/src | 53 | idevicepair_CFLAGS = $(AM_CFLAGS) |
15 | idevicepair_LDFLAGS = $(AM_LDFLAGS) | 54 | idevicepair_LDFLAGS = $(AM_LDFLAGS) $(libusbmuxd_LIBS) $(ssl_lib_LIBS) |
16 | idevicepair_LDADD = ../src/libimobiledevice.la | 55 | idevicepair_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la $(limd_glue_LIBS) |
17 | 56 | ||
18 | idevicesyslog_SOURCES = idevicesyslog.c | 57 | idevicesyslog_SOURCES = idevicesyslog.c |
19 | idevicesyslog_CFLAGS = $(AM_CFLAGS) | 58 | idevicesyslog_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) |
20 | idevicesyslog_LDFLAGS = $(AM_LDFLAGS) | 59 | idevicesyslog_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) |
21 | idevicesyslog_LDADD = ../src/libimobiledevice.la | 60 | idevicesyslog_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la |
22 | 61 | ||
23 | idevice_id_SOURCES = idevice_id.c | 62 | idevice_id_SOURCES = idevice_id.c |
24 | idevice_id_CFLAGS = $(AM_CFLAGS) | 63 | idevice_id_CFLAGS = $(AM_CFLAGS) |
25 | idevice_id_LDFLAGS = $(AM_LDFLAGS) | 64 | idevice_id_LDFLAGS = $(AM_LDFLAGS) |
26 | idevice_id_LDADD = ../src/libimobiledevice.la | 65 | idevice_id_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la |
27 | 66 | ||
28 | idevicebackup_SOURCES = idevicebackup.c | 67 | idevicebackup_SOURCES = idevicebackup.c |
29 | idevicebackup_CFLAGS = $(AM_CFLAGS) | 68 | idevicebackup_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) |
30 | idevicebackup_LDFLAGS = $(AM_LDFLAGS) | 69 | idevicebackup_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) |
31 | idevicebackup_LDADD = ../src/libimobiledevice.la | 70 | idevicebackup_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la |
71 | |||
72 | idevicebackup2_SOURCES = idevicebackup2.c | ||
73 | idevicebackup2_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) | ||
74 | idevicebackup2_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) | ||
75 | idevicebackup2_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
32 | 76 | ||
33 | ideviceimagemounter_SOURCES = ideviceimagemounter.c | 77 | ideviceimagemounter_SOURCES = ideviceimagemounter.c |
34 | ideviceimagemounter_CFLAGS = $(AM_CFLAGS) | 78 | ideviceimagemounter_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) $(libtatsu_CFLAGS) |
35 | ideviceimagemounter_LDFLAGS = $(AM_LDFLAGS) | 79 | ideviceimagemounter_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) $(ssl_lib_LIBS) $(libtatsu_LIBS) |
36 | ideviceimagemounter_LDADD = ../src/libimobiledevice.la | 80 | ideviceimagemounter_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la |
37 | 81 | ||
38 | idevicescreenshot_SOURCES = idevicescreenshot.c | 82 | idevicescreenshot_SOURCES = idevicescreenshot.c |
39 | idevicescreenshot_CFLAGS = $(AM_CFLAGS) | 83 | idevicescreenshot_CFLAGS = $(AM_CFLAGS) |
40 | idevicescreenshot_LDFLAGS = $(AM_LDFLAGS) | 84 | idevicescreenshot_LDFLAGS = $(AM_LDFLAGS) |
41 | idevicescreenshot_LDADD = ../src/libimobiledevice.la | 85 | idevicescreenshot_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la |
42 | 86 | ||
43 | ideviceenterrecovery_SOURCES = ideviceenterrecovery.c | 87 | ideviceenterrecovery_SOURCES = ideviceenterrecovery.c |
44 | ideviceenterrecovery_CFLAGS = $(AM_CFLAGS) | 88 | ideviceenterrecovery_CFLAGS = $(AM_CFLAGS) |
45 | ideviceenterrecovery_LDFLAGS = $(AM_LDFLAGS) | 89 | ideviceenterrecovery_LDFLAGS = $(AM_LDFLAGS) |
46 | ideviceenterrecovery_LDADD = ../src/libimobiledevice.la | 90 | ideviceenterrecovery_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la |
47 | 91 | ||
48 | idevicedate_SOURCES = idevicedate.c | 92 | idevicedate_SOURCES = idevicedate.c |
49 | idevicedate_CFLAGS = $(AM_CFLAGS) | 93 | idevicedate_CFLAGS = $(AM_CFLAGS) |
50 | idevicedate_LDFLAGS = $(AM_LDFLAGS) | 94 | idevicedate_LDFLAGS = $(AM_LDFLAGS) |
51 | idevicedate_LDADD = ../src/libimobiledevice.la | 95 | idevicedate_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la |
96 | |||
97 | ideviceprovision_SOURCES = ideviceprovision.c | ||
98 | ideviceprovision_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) | ||
99 | ideviceprovision_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) | ||
100 | ideviceprovision_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
101 | |||
102 | idevicedebugserverproxy_SOURCES = idevicedebugserverproxy.c | ||
103 | idevicedebugserverproxy_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) | ||
104 | idevicedebugserverproxy_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) | ||
105 | idevicedebugserverproxy_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
106 | |||
107 | idevicediagnostics_SOURCES = idevicediagnostics.c | ||
108 | idevicediagnostics_CFLAGS = $(AM_CFLAGS) | ||
109 | idevicediagnostics_LDFLAGS = $(AM_LDFLAGS) | ||
110 | idevicediagnostics_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
111 | |||
112 | idevicedebug_SOURCES = idevicedebug.c | ||
113 | idevicedebug_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) | ||
114 | idevicedebug_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) | ||
115 | idevicedebug_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
116 | |||
117 | idevicedevmodectl_SOURCES = idevicedevmodectl.c | ||
118 | idevicedevmodectl_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) | ||
119 | idevicedevmodectl_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) | ||
120 | idevicedevmodectl_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la | ||
121 | |||
122 | idevicenotificationproxy_SOURCES = idevicenotificationproxy.c | ||
123 | idevicenotificationproxy_CFLAGS = $(AM_CFLAGS) | ||
124 | idevicenotificationproxy_LDFLAGS = $(AM_LDFLAGS) | ||
125 | idevicenotificationproxy_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
126 | |||
127 | idevicecrashreport_SOURCES = idevicecrashreport.c | ||
128 | idevicecrashreport_CFLAGS = $(AM_CFLAGS) $(limd_glue_CFLAGS) | ||
129 | idevicecrashreport_LDFLAGS = $(AM_LDFLAGS) $(limd_glue_LIBS) | ||
130 | idevicecrashreport_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
131 | |||
132 | idevicesetlocation_SOURCES = idevicesetlocation.c | ||
133 | idevicesetlocation_CFLAGS = $(AM_CFLAGS) | ||
134 | idevicesetlocation_LDFLAGS = $(AM_LDFLAGS) | ||
135 | idevicesetlocation_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la | ||
136 | |||
137 | afcclient_SOURCES = afcclient.c | ||
138 | afcclient_CFLAGS = $(AM_CFLAGS) | ||
139 | afcclient_LDFLAGS = $(AM_LDFLAGS) | ||
140 | if HAVE_READLINE | ||
141 | afcclient_CFLAGS += $(readline_CFLAGS) | ||
142 | afcclient_LDFLAGS += $(readline_LIBS) | ||
143 | endif | ||
144 | afcclient_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(limd_glue_LIBS) | ||