summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..80b0eae
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,14 @@
1AUTOMAKE_OPTIONS = foreign
2ACLOCAL_AMFLAGS = -I m4
3SUBDIRS = src include tools udev
4
5EXTRA_DIST = \
6 README.md \
7 git-version-gen
8
9dist-hook:
10 @if ! git diff --quiet; then echo "Uncommitted changes present; not releasing"; exit 1; fi
11 echo $(VERSION) > $(distdir)/.tarball-version
12
13DISTCHECK_CONFIGURE_FLAGS = \
14 --with-udevrulesdir=$$dc_install_base/$(udevrulesdir)