summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2011-09-26 15:09:09 +0200
committerGravatar Nikias Bassen2011-09-26 15:09:09 +0200
commitda1c7787659973b2ace32731f0eb7d1bfeecd340 (patch)
tree3cb844b4c1578c526893cd8b5caf24422d944725 /CMakeLists.txt
parent13ecca44eefd367354070a22dec7c0829e1ba6fd (diff)
downloadlibplist-da1c7787659973b2ace32731f0eb7d1bfeecd340.tar.gz
libplist-da1c7787659973b2ace32731f0eb7d1bfeecd340.tar.bz2
move cmake endianess detection to proper place and actually USE it
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a13546e..342ff91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,10 @@ To do so, perform the following steps in the base directory:
Then, run cmake again.")
ENDIF()
+INCLUDE (TestBigEndian)
+TEST_BIG_ENDIAN(endianess)
+SET ( PLIST_BYTE_ORDER ${endianess} )
+
ADD_SUBDIRECTORY( libcnary )
ADD_SUBDIRECTORY( src )
ADD_SUBDIRECTORY( plutil )
@@ -49,10 +53,6 @@ IF ( SWIG_FOUND AND PYTHONLIBS_FOUND AND PYTHONINTERP_FOUND )
ADD_SUBDIRECTORY( swig )
ENDIF ( SWIG_FOUND AND PYTHONLIBS_FOUND AND PYTHONINTERP_FOUND )
-INCLUDE (TestBigEndian)
-TEST_BIG_ENDIAN(endianess)
-SET ( PLIST_BYTE_ORDER ${endianess} )
-
# add uninstall target
CONFIGURE_FILE( "${CMAKE_SOURCE_DIR}/cmake/modules/cmake_uninstall.cmake.in" "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake" IMMEDIATE @ONLY)
ADD_CUSTOM_TARGET(uninstall "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")