summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Jonathan Beck2009-01-04 12:31:41 +0100
committerGravatar Jonathan Beck2009-01-04 12:31:41 +0100
commitca40090460a6e43112c1f9e9d414727c29a9847d (patch)
treea439dad5ab5ee03d604ae363adec77ae9f979d59 /configure.ac
parent135e43c1767c6d1cc4cad057130bf371a548f648 (diff)
downloadlibplist-ca40090460a6e43112c1f9e9d414727c29a9847d.tar.gz
libplist-ca40090460a6e43112c1f9e9d414727c29a9847d.tar.bz2
Setup warning flags and fixes missing static attribute for local funtions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa3a2e2..4af0e49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,7 @@ AC_INIT(libplist, 0.1.0, nospam@nowhere.com)
AM_INIT_AUTOMAKE(libplist, 0.1.0)
AC_CONFIG_SRCDIR([src/])
AC_CONFIG_HEADER([config.h])
+AC_CONFIG_MACRO_DIR([m4])
AC_PROG_LIBTOOL
@@ -44,4 +45,7 @@ if test "$no_debug_code" = true; then
AC_DEFINE(STRIP_DEBUG_CODE,1,[Strip debug reporting code])
fi
+AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default")
+AC_SUBST(GLOBAL_CFLAGS)
+
AC_OUTPUT(Makefile src/Makefile include/Makefile plutil/Makefile libplist-1.0.pc)